aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-03-06 14:56:42 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:23 +0100
commit08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5 (patch)
treef23730a5c9126fe9d99b14285ee3a9bff25886a3 /meta-python/recipes-devtools/python/python-m2crypto
parent7c43e026b1151e3c468fe8432dc1c35cd0122421 (diff)
downloadmeta-openembedded-contrib-08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5.tar.gz
python-m2crypt: update package to 0.23.0
this happens to fix the cdra build issue related to the openssl 1.0.2g update. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch35
1 files changed, 16 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index bcbdf24bb5..819c8e5697 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -10,30 +10,27 @@ Upstream-status: Unknown
setup.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
-diff --git a/setup.py b/setup.py
-index e7c49eb..8deaa34 100644
---- a/setup.py
-+++ b/setup.py
-@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+Index: M2Crypto-0.23.0/setup.py
+===================================================================
+--- M2Crypto-0.23.0.orig/setup.py
++++ M2Crypto-0.23.0/setup.py
+@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_
self.openssl = 'c:\\pkg'
else:
self.libraries = ['ssl', 'crypto']
- self.openssl = '/usr'
+ self.openssl = os.environ.get( "STAGING_DIR" )
-
-
+
def finalize_options(self):
-@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+ '''Overloaded build_ext implementation to append custom openssl
+@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_
+ if _openssl and os.path.isdir(_openssl):
+ self.openssl = _openssl
- build_ext.build_ext.finalize_options(self)
+- self.include_dirs.append(os.path.join(self.openssl, 'include'))
+- openssl_library_dir = os.path.join(self.openssl, 'lib')
++ self.include_dirs.append(os.environ.get( "STAGING_INCDIR" ))
++ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
-- opensslIncludeDir = os.path.join(self.openssl, 'include')
-- opensslLibraryDir = os.path.join(self.openssl, 'lib')
-+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
-+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
-
- self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
- [opensslIncludeDir]]
---
-1.8.1.4
-
+ if platform.system() == "Linux":
+ if _multiarch: # on Fedora/RHEL it is an empty string