aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-23 12:13:47 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:33:06 +0100
commit06f04adf4b6572f79839240bdd6e0b0f389bbc08 (patch)
treee03e40b6d324090e3313c6e224f2b3c54c08602b /meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
parent2463e39c449cb3431e28a2a1ed5c31f778bf47bc (diff)
downloadmeta-openembedded-contrib-06f04adf4b6572f79839240bdd6e0b0f389bbc08.tar.gz
python-cryptography, python-cryptography-vectors: uprev
Pick up many fixes and enhancements made since 0.8.1 was released. See: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst The uprev requires an uprev of pyasn1 and also pulls in two new packages idna and ipaddress. The idna software has 3 licenses, one of which is the 'Unicode' license: http://www.unicode.org/copyright.html Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb b/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
new file mode 100644
index 0000000000..202e4dc0c5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyasn1_0.1.9.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python library implementing ASN.1 types."
+HOMEPAGE = "http://pyasn1.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=425e62320d430219736139b134db2fc4"
+DEPENDS = "python"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pyasn1/pyasn1-${PV}.tar.gz"
+SRC_URI[md5sum] = "f00a02a631d4016818659d1cc38d229a"
+SRC_URI[sha256sum] = "853cacd96d1f701ddd67aa03ecc05f51890135b7262e922710112f12a2ed2a7f"
+
+S = "${WORKDIR}/pyasn1-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-lang python-shell"