aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-02-06 08:37:15 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:30 +0100
commita625494863b70f13ca29b4b0322fbfd5a8a073d9 (patch)
tree08f898342ab32db5a4bfd70e1430eb30160107db /meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
parent2b6cad9522582b0816251b5efbbc4601d037ae0e (diff)
downloadmeta-openembedded-contrib-a625494863b70f13ca29b4b0322fbfd5a8a073d9.tar.gz
python-pycrypto: add app to meta-python
move it from meta-security Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 0000000000..06a0cc4444
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,11 @@
+inherit distutils
+require python-pycrypto.inc
+
+SRC_URI += "file://cross-compiling.patch"
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils_do_install
+}