aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest.inc
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-07-05 10:00:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:31 +0200
commitc974fbf9ebf185552ab65301e07af44f36517abf (patch)
treee5df11fa16ca50f17ad4ea1d81c64ff588609690 /meta-python/recipes-devtools/python/python-pytest.inc
parent941ad264a6f9e6b21860c3834ce235b791912972 (diff)
downloadmeta-openembedded-contrib-c974fbf9ebf185552ab65301e07af44f36517abf.tar.gz
python-pytest: remove fetch during do_compile phase
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 22795964df..b5c1fa82a7 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c39b24965f4aef64222cb35de9d47cc4"
SRC_URI[md5sum] = "35356e6e31cbd8318e8b2a8340a90b72"
SRC_URI[sha256sum] = "095e1832f7e424563c95daf4d8d3c865052b80e139cdd2f9610a986ee8526206"
+SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch"
+
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-argparse \
${PYTHON_PN}-debugger \
@@ -13,4 +15,6 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-setuptools \
"
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
+
BBCLASSEXTEND = "native nativesdk"