aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-03-25 18:56:21 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-01 15:33:56 +0200
commitbd6d6eee6ff98d4d2bbcf68d717bce44696cf89a (patch)
treeb0198befc65b0f5ee9c9aa86019931d8ec2c908b /meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb
parent6ddf37ad7672a4ccae09d5ba304ed5be47048437 (diff)
downloadmeta-openembedded-contrib-bd6d6eee6ff98d4d2bbcf68d717bce44696cf89a.tar.gz
python-pyudev: update to 0.19.0
Signed-off-by: Derek Straka <derek@asterius.io>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb b/meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb
new file mode 100644
index 0000000000..aa26dc7d96
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyudev_0.19.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A libudev binding"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI[md5sum] = "1151e9d05baf6ce7b43e7574dc0ef154"
+SRC_URI[sha256sum] = "5abcbd03e4965110d1fedcbdd5532974cb4638ceef34337aa2d5758eceb54ad3"
+
+inherit pypi setuptools
+
+do_configure_prepend() {
+ sed -i "/import pyudev/d" ${S}/setup.py
+ sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
+}
+
+RDEPENDS_${PN} = "\
+ python-ctypes \
+ python-subprocess \
+ python-misc \
+ python-contextlib \
+"