aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-02-13 09:53:53 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commitf54a98d4087757813fc1a08d9a8d19a2f5dd9c3a (patch)
treea70025977a2f8dbfb2f25c09c19d9089e722f341 /meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
parenta84b65c7d079d6205bd45b32b55231faeea9938b (diff)
downloadmeta-openembedded-contrib-f54a98d4087757813fc1a08d9a8d19a2f5dd9c3a.tar.gz
python-pyzmq: Add recipe for Python Zero Message Queue bindings.
Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
new file mode 100644
index 0000000000..2dc3b73f9e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -0,0 +1,26 @@
+diff --git a/setup.py b/setup.py
+index 62df445..1fdbdeb 100755
+--- a/setup.py
++++ b/setup.py
+@@ -213,12 +213,6 @@ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
+ pass
+ # unused rpath args for OS X:
+ # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/..']
+- else:
+- settings['runtime_library_dirs'] += ['$ORIGIN/..']
+- elif sys.platform != 'darwin':
+- settings['runtime_library_dirs'] += [
+- os.path.abspath(x) for x in settings['library_dirs']
+- ]
+
+ return settings
+
+@@ -592,8 +586,6 @@ class Configure(build_ext):
+ pass
+ # unused rpath args for OS X:
+ # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/../zmq']
+- else:
+- settings['runtime_library_dirs'] = [ os.path.abspath(pjoin('.', 'zmq')) ]
+
+ line()
+ info("Configure: Autodetecting ZMQ settings...")