aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-02-22 10:46:29 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:47:27 +0100
commit43847c52645674f352518bbd1467cd1d8971b4bb (patch)
tree563419e3ab29e6ad118886b38a2023db725b213a /meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb
parent81fe3b83d7a909d19fe2bb2b88c69802f966b421 (diff)
downloadmeta-openembedded-contrib-43847c52645674f352518bbd1467cd1d8971b4bb.tar.gz
python-tornado-redis: add recipe
Tornado-Redis is a Redis client for Tornado web server, intended for asyncronous handling of Redis pub/sub and blocking list commands Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb b/meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb
new file mode 100644
index 0000000000..daec25eacd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado-redis_2.4.18.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tornado-Redis is an asyncronous Redis client for the Tornado Web Server"
+DESCRIPTION = "Tornado-Redis is a Redis client that uses Tornado's native 'tornado-gen' interface. \
+It can be used alongside redis-py in Tornado applications: \
+tornado-redis to subscribe to Pub/Sub notifications and for blocking commands (such as BLPOP, BRPOP, BRPOPLPUSH); \
+redis-py for other commands."
+HOMEPAGE = "https://github.com/leporo/tornado-redis"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=ca307e8f37b5fa7f8dbbec033f7db7de"
+
+SRCNAME = "tornado-redis"
+
+SRC_URI = " \
+ https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "1c7ec0f645d15400871141c1149e6934"
+SRC_URI[sha256sum] = "8fd3b324158291ad5fb7f5f8dc2e8763b2895556bd2a44f2dd721b703c669046"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-tornado"
+
+RDEPENDS_${PN}-test += "${PN} python-tornado"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"