aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-ujson_1.33.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-ujson_1.33.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-contrib-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-ujson_1.33.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-ujson_1.33.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-ujson_1.33.bb b/meta-python/recipes-devtools/python/python-ujson_1.33.bb
index 8fdd2b8351..dbe432abdf 100644
--- a/meta-python/recipes-devtools/python/python-ujson_1.33.bb
+++ b/meta-python/recipes-devtools/python/python-ujson_1.33.bb
@@ -1,21 +1,14 @@
SUMMARY = "Ultra fast JSON encoder and decoder for Python"
DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
-HOMEPAGE = "https://pypi.python.org/pypi/ujson"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5b206f6ba5e41c60df8cdcddf79a3d82"
-SRCNAME = "ujson"
-
-SRC_URI = " \
- http://pypi.python.org/packages/source/u/ujson/${SRCNAME}-${PV}.zip \
-"
-
SRC_URI[md5sum] = "8148a2493fff78940feab1e11dc0a893"
SRC_URI[sha256sum] = "68cf825f227c82e1ac61e423cfcad923ff734c27b5bdd7174495d162c42c602b"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+PYPI_PACKAGE = "ujson"
+PYPI_PACKAGE_EXT = "zip"
+inherit pypi setuptools
RDEPENDS_${PN} += "python-numbers"