aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-10-13 13:07:59 -0400
committerKhem Raj <raj.khem@gmail.com>2023-10-13 13:23:05 -0700
commit349546c72fb786b4b1dcb3e748a44986d235b99d (patch)
tree018b45184dab01790d7befff53cfd892acecb4fe /meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
parente0abbc52802d36cbd6e5c15c38d6649a822e6450 (diff)
downloadmeta-openembedded-contrib-349546c72fb786b4b1dcb3e748a44986d235b99d.tar.gz
python3-arrow: add from meta-patchtest
arrow is a module that aims to provide a more user-friendly approach to date and time in Python. It is required by git-pw which in turn is required by patchtest, so add a recipe for it. The version is updated 1.2.2 -> 1.3.0 from the meta-patchtest layer. Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
new file mode 100644
index 0000000000..ec49d04eb9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Better dates and times for Python"
+HOMEPAGE = "https://github.com/crsmithdev/arrow"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d"
+
+SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85"
+
+inherit setuptools3 pypi
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-dateutil \
+ "