aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-babel_2.9.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-10 17:07:21 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:25:56 -0700
commit0f7eec8da9a5b37856df54f26d8abb2b85f86028 (patch)
tree00bdcc24434e9dcf6fd10f369db8e9866540398f /meta-python/recipes-devtools/python/python3-babel_2.9.1.bb
parent178ef37ed7dd2c7febed859f78c27bbf51040cef (diff)
downloadmeta-openembedded-contrib-0f7eec8da9a5b37856df54f26d8abb2b85f86028.tar.gz
python3-babel: Upgrade 2.9.0 -> 2.9.1
Upgrade to release 2.9.1: - The internal locale-data loading functions now validate the name of the locale file to be loaded and only allow files within Babel's data directory. Thanks to Chris Lyne of Tenable, Inc. for discovering the issue! License-Update: Update years Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-babel_2.9.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-babel_2.9.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-babel_2.9.1.bb b/meta-python/recipes-devtools/python/python3-babel_2.9.1.bb
new file mode 100644
index 0000000000..a54f0d2100
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-babel_2.9.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A collection of tools for internationalizing Python applications"
+HOMEPAGE = "http://babel.edgewall.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=05fb707293a85504aa67afc8ea34d747"
+
+SRC_URI[sha256sum] = "bc0c176f9f6a994582230df350aa6e05ba2ebe4b3ac317eab29d9be5d2768da0"
+
+PYPI_PACKAGE = "Babel"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"