aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-03-24 17:17:59 +0800
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-28 08:35:32 -0400
commit0e469258cfd70a827381bc0607ff93c984406e93 (patch)
tree9b79a363f0bcbeac7931c50134fdc151711a9352 /meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb
parent4b32f597170d6b51c757ac06ba0a3f4113e98190 (diff)
downloadmeta-openembedded-contrib-0e469258cfd70a827381bc0607ff93c984406e93.tar.gz
python3-cantools: upgrade 37.0.1 -> 37.0.7
Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb b/meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb
new file mode 100644
index 0000000000..c179071afa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cantools_37.0.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "CAN BUS tools in Python 3."
+HOMEPAGE = "https://github.com/eerimoq/cantools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
+
+SRC_URI[sha256sum] = "e603a7e1e40f5b4963c4c64cf4b013264afa009e232a878c73d31c29942e4466"
+
+PYPI_PACKAGE = "cantools"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-can \
+ ${PYTHON_PN}-bitstruct \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-textparser \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-diskcache \
+"
+
+CLEANBROKEN = "1"