aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-08-22 17:18:27 +0300
committerKhem Raj <raj.khem@gmail.com>2022-08-22 14:12:05 -0700
commitded72cdc8b4b242a0c6616ea3966d3895b4ccb86 (patch)
tree7dd92af9783ea624e75b162ee64681fb2f33ff4b /meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
parent821e2e0cdf582c5079170a90dff4358fa2cac103 (diff)
downloadmeta-openembedded-contrib-ded72cdc8b4b242a0c6616ea3966d3895b4ccb86.tar.gz
python3-coverage: Upgrade 6.4.1 -> 6.4.4
Upgrade to release 6.4.4: - Wheels are now provided for Python 3.11 - Fix a failure when combining data files if the file names contained glob-like patterns - Fix a messaging failure when combining Windows data files on a different drive than the current directory - Fix path calculations when running in the root directory, as you might do in a Docker container - Filtering in the HTML report wouldn't work when reloading the index page. This is now fixed - Fix a problem with Cython code measurement Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb b/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
new file mode 100644
index 0000000000..5bff96901c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_6.4.4.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Code coverage measurement for Python"
+HOMEPAGE = "https://coverage.readthedocs.io"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "e16c45b726acb780e1e6f88b286d3c10b3914ab03438f32117c4aa52d7f30d58"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-io \
+"