aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:11:48 -0700
committerTim Orling <timothy.t.orling@intel.com>2021-11-01 15:23:05 +0000
commit2ff0041029d22c316e45085bd131ae9c726a6030 (patch)
treefa5f3a5368c109170c3931d94adca7c45afcd8cb /meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
parent0329049c145a7ca87778cf139bf88f18c8f79172 (diff)
downloadmeta-openembedded-contrib-2ff0041029d22c316e45085bd131ae9c726a6030.tar.gz
python3-cryptography: upgrade 3.3.2 -> 35.0.0
Add PSF-2.0 license and explicitly add checksums for the LICENSE files that are packaged. RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the patch for skipping. DEPENDS on python3-setuptools-rust-native RDEPENDS on python3-pytest-subtests for ptest Need to inherit cargo, otherwise build_rust will fail to detect Rust compiler. Also, so that RUST_TARGET_PATH is exported, otherwise build_rust will fail because 'rustc --print cfg' doesn't know where the target specifications are. Copy pyproject.toml for ptest as it defines the pytest.marker(s) needed Cleanup and alphabetize the RDEPENDS Inherit python3-dir for the -dbg files for hazmat. Export PYO3_CROSS, PYO3_CROSS_LIB_DIR, PYO3_CROSS_INCLUDE_DIR and CARGO_BUILD_TARGET to inform setuptools-rust we are cross-compiling. Export RUSTFLAGS so cargo can find 'std' and 'core' for target Need to call cargo_common_do_configure to setup cargo_home/config so that the linker properly finds e.g. crti.o and crtbeginS.o However, bitbake vendoring does not appear to work with setuptools-rust, as it errors out immediately because it cannot find package pyo3: CARGO_DISABLE_BITBAKE_VENDORING = "1" FIXME: on qemux86-musl, do_install tries to rebuild Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
deleted file mode 100644
index baec105a3e..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-SUMMARY = "Provides cryptographic recipes and primitives to python developers"
-HOMEPAGE = "https://cryptography.io/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0 | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
-
-LDSHARED += "-pthread"
-
-SRC_URI[sha256sum] = "5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29e19bed"
-
-SRC_URI += " \
- file://run-ptest \
- file://h-test.patch \
-"
-
-inherit pypi setuptools3
-
-DEPENDS += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-cffi-native \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-six \
-"
-
-RDEPENDS:${PN} += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-idna \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-setuptools \
- ${PYTHON_PN}-six \
-"
-
-RDEPENDS:${PN}:class-target += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-idna \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-setuptools \
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-threading \
-"
-
-RDEPENDS:${PN}-ptest += " \
- ${PN} \
- ${PYTHON_PN}-cryptography-vectors \
- ${PYTHON_PN}-iso8601 \
- ${PYTHON_PN}-pretend \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytz \
-"
-
-inherit ptest
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
- install -d ${D}${PTEST_PATH}/tests/hazmat
- cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
-}
-
-FILES:${PN}-dbg += " \
- ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
-"
-
-BBCLASSEXTEND = "native nativesdk"