aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cython_0.24.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-04-11 07:41:34 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-21 21:33:18 +0200
commit4a90cbc29bae064780e15a30c399bb3dc04bed8d (patch)
tree98cbf410d7b3f3cda40ebec05ebfdcad37c49ad5 /meta-python/recipes-devtools/python/python3-cython_0.24.bb
parentead0d3b0c8635a8d61655a57b9d5e43b86c67b6e (diff)
downloadmeta-openembedded-contrib-4a90cbc29bae064780e15a30c399bb3dc04bed8d.tar.gz
python-cython: update to 0.24
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cython_0.24.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cython_0.24.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cython_0.24.bb b/meta-python/recipes-devtools/python/python3-cython_0.24.bb
new file mode 100644
index 0000000000..2ce6bdbd68
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cython_0.24.bb
@@ -0,0 +1,18 @@
+inherit setuptools3
+require python-cython.inc
+
+RDEPENDS_${PN} += "\
+ python3-setuptools \
+"
+
+# running build_ext a second time during install fails, because Python
+# would then attempt to import cythonized modules built for the target
+# architecture.
+DISTUTILS_INSTALL_ARGS += "--skip-build"
+
+do_install_append() {
+ # rename scripts that would conflict with the Python 2 build of Cython
+ mv ${D}${bindir}/cython ${D}${bindir}/cython3
+ mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
+ mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
+}