aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-29 12:20:22 +0300
committerKhem Raj <raj.khem@gmail.com>2021-03-30 09:04:35 -0700
commit2dd90550bc23417e31f6eba49c69f066cb3895ae (patch)
tree820de5ed0975c0a39c7d6cb7703f4cca0ee71d49 /meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb
parentea648569cc804618bd41b91d62140e17cb82a998 (diff)
downloadmeta-openembedded-contrib-2dd90550bc23417e31f6eba49c69f066cb3895ae.tar.gz
python3-djangorestframework: Upgrade 3.12.3 -> 3.12.4
Upgrade to release 3.12.4: - Revert use of deque instead of list for tracking throttling .history. Due to incompatibility with DjangoRedis cache backend. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb
new file mode 100644
index 0000000000..417e36721a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.4.bb
@@ -0,0 +1,16 @@
+SUMMARY = "djangorestframework"
+DESCRIPTION = "pip3 install djangorestframework"
+HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
+
+SRC_URI[sha256sum] = "f747949a8ddac876e879190df194b925c177cdeb725a099db1460872f7c0a7f2"
+
+PYPI_PACKAGE = "djangorestframework"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-django \
+"