aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2022-03-30 00:22:58 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-30 07:51:38 -0700
commit8781a8fbcb7ac8b703fcf6175c4f57cf744e1d4b (patch)
treedd2c15156b2f7a646050b8e379c74cef5a876abb /meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
parent7eace39caf91aeb18a5f69d577e792046f704772 (diff)
downloadmeta-openembedded-contrib-8781a8fbcb7ac8b703fcf6175c4f57cf744e1d4b.tar.gz
python3-evdev: fix host header contamination
The attempt to pass in correct headers was being ignored, because it never got updated after distutils class was removed. Switch to SETUPTOOLS_BUILD_ARGS, which setuptools3 class does pay attention to. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
index 97a8aedd79..ca324c9ae9 100644
--- a/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
@@ -11,7 +11,7 @@ do_compile:prepend() {
rm -rf ${S}/evdev/ecodes.c
}
-DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
+SETUPTOOLS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
RDEPENDS:${PN} += "\
${PYTHON_PN}-ctypes \