aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-11 14:44:30 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commitb56cd509583f18b7f78338dfac339c1a75f7e09e (patch)
tree5d607fc03b9acfa01ceaaa68990980ca9d77dd07 /meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb
parenta5e99dd2693a36bc2750d8d59fc3f786758caebf (diff)
downloadmeta-openembedded-contrib-b56cd509583f18b7f78338dfac339c1a75f7e09e.tar.gz
python3-flask-login: Upgrade 0.4.1 -> 0.5.0
Upgrade to release 0.5.0: - New custom test client: `flask_login.FlaskLoginClient`. You can use this to write clearer automated tests. - Prefix authenticated user_id, remember, and remember_seconds in Flask Session with underscores to prevent accidental usage in application code. - Simplify user loading. - Various documentation improvements. - Set session ID when setting next. - Clear session identifier on logout. - Ensure use of a safe and up-to-date version of Flask. - Drop support of Python versions: 2.6, 3.3, 3.4 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb b/meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb
new file mode 100644
index 0000000000..d776ce9682
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-login_0.5.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "User session management for Flask"
+DESCRIPTION = "Flask-Login provides user session management for Flask. \
+It handles the common tasks of logging in, logging out, and remembering \
+your users’ sessions over extended periods of time."
+HOMEPAGE = " https://github.com/maxcountryman/flask-login"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8aa87a1cd9fa41d969ad32cfdac2c596"
+
+SRC_URI[md5sum] = "a2d94aa6ae935345ebc68eb3cbb5fccd"
+SRC_URI[sha256sum] = "6d33aef15b5bcead780acc339464aae8a6e28f13c90d8b1cf9de8b549d1c0b4b"
+
+PYPI_PACKAGE = "Flask-Login"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target = "${PYTHON_PN}-flask"