aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-29 17:22:16 +0300
committerKhem Raj <raj.khem@gmail.com>2021-07-06 09:40:42 -0700
commite5eee28bec7dc72bf87f488bde4a5e7393f4af63 (patch)
tree9bf42813b833cc9b5844974a4c25a5038dcbc9da /meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
parent5671f3b02cf2a97f30e25d975b270f7fac976f07 (diff)
downloadmeta-openembedded-contrib-e5eee28bec7dc72bf87f488bde4a5e7393f4af63.tar.gz
python3-ipython: Upgrade 7.24.1 -> 7.25.0
Upgrade to release 7.25.0 with a single bugfix, which is highly recommended for all users of ipdb, ipython debugger %debug magic and similar. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb b/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
new file mode 100644
index 0000000000..b8a6db2b11
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_7.25.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "IPython: Productive Interactive Computing"
+HOMEPAGE = "https://ipython.org"
+AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
+
+PYPI_PACKAGE = "ipython"
+
+SRC_URI[sha256sum] = "54bbd1fe3882457aaf28ae060a5ccdef97f212a741754e420028d4ec5c2291dc"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-jedi \
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-pickleshare \
+ ${PYTHON_PN}-traitlets \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-backcall \
+ ${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-pexpect \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-sqlite3 \
+"
+
+inherit setuptools3 pypi