aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-19 19:37:44 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-20 09:30:38 -0800
commitc29e71f271f52387613d4fddd2b0c30a573fceae (patch)
tree563537d4aad26d927c21aacfcf117fea2e669155 /meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
parent03aa496511aba0709539c66063ffad5e67f87409 (diff)
downloadmeta-openembedded-contrib-c29e71f271f52387613d4fddd2b0c30a573fceae.tar.gz
python3-pymysql: Upgrade 0.10.1 -> 1.0.2
Upgrade to release 1.0.2: - Fix user, password, host, database are still positional arguments. All arguments of connect() are now keyword-only. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb b/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
new file mode 100644
index 0000000000..36e2921ae6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
@@ -0,0 +1,16 @@
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[sha256sum] = "816927a350f38d56072aeca5dfb10221fe1dc653745853d30a216637f5d7ad36"
+
+PYPI_PACKAGE = "PyMySQL"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"