aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-07-15 11:59:36 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-15 12:48:34 -0400
commite560ab2ebd8b358f5434c7450ecea5d130dc31fd (patch)
tree1fd5a17adfa6029a42049ad8c82673d523c26bde /meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb
parentdcbfed89d4fc0b4805b5d2c75c28c613169a9600 (diff)
downloadmeta-openembedded-contrib-e560ab2ebd8b358f5434c7450ecea5d130dc31fd.tar.gz
python3-ujson: upgrade 5.3.0 -> 5.4.0
Changelog: ========= Added ------ Add support for arbitrary size integers (#548) Fixed --------- CVE-2022-31116: Replace wchar_t string decoding implementation with a uint32_t-based one (#555) Fix handling of surrogates on decoding (#550) CVE-2022-31117: Potential double free of buffer during string decoding Fix memory leak on encoding errors when the buffer was resized (#549) Integer parsing: always detect overflows (#544) Fix handling of surrogates on encoding (#530) Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb
new file mode 100644
index 0000000000..15cf80e36f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_5.4.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Ultra fast JSON encoder and decoder for Python"
+DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a"
+
+SRC_URI[sha256sum] = "6b953e09441e307504130755e5bd6b15850178d591f66292bba4608c4f7f9b00"
+
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+ file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytz \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"