aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb
diff options
context:
space:
mode:
authorMaciej Pijanowski <maciej.pijanowski@3mdeb.com>2019-08-11 17:16:20 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-11 08:58:05 -0700
commit21e53693ac7e5603da384f17ca1e9eb81b0706de (patch)
tree62936a825a7be1db6ad95d504eb65523115fc20b /meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb
parent3947b77ac374952ace622d7860a9662092e6dea3 (diff)
downloadmeta-openembedded-contrib-21e53693ac7e5603da384f17ca1e9eb81b0706de.tar.gz
python3-websockets: upgrade to 8.0.2
The present version was not compatible with python 3.7 because async is now the proper keyword. The reported werror was: asyncio_ensure_future = asyncio.async # Python < 3.5 ^ SyntaxError: invalid syntax Issues like this one: https://github.com/psf/requests-html/issues/65 explains the reason of that. Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb b/meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb
new file mode 100644
index 0000000000..6da73ce358
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websockets_8.0.2.bb
@@ -0,0 +1,16 @@
+SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
+HOMEPAGE = "https://github.com/aaugustin/websockets"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ad5c6d36b3d0098b2f33a5ab69a9e750"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "a37f0e22c3aa5f1cf12a6a3ae22b36ca"
+SRC_URI[sha256sum] = "882a7266fa867a2ebb2c0baaa0f9159cabf131cf18c1b4270d79ad42f9208dc5"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"