aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-12 21:05:44 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-16 08:25:15 -0800
commit3053ff76249cd20db3c6e29212b7fe7c9280cfb0 (patch)
tree350f25496b69fcae1e37e244ce030fe1c4e28eb3 /meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb
parent2f670f6e7a3e29f52606725e7043e884fafec8f9 (diff)
downloadmeta-openembedded-contrib-3053ff76249cd20db3c6e29212b7fe7c9280cfb0.tar.gz
python3-yarl: Upgrade 1.7.0 -> 1.7.2
Upgrade to release 1.7.2: - Changed call in with_port() to stop reencoding parts of the URL that were already encoded. - Fix 1.7.0 build error Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb b/meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb
new file mode 100644
index 0000000000..0867d1cb53
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.7.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e581798a7b985311f29fa3e163ea27ae"
+
+SRC_URI[sha256sum] = "45399b46d60c253327a460e99856752009fcee5f5d3c80b2f7c0cae1c38d56dd"
+
+SRC_URI += "file://run-ptest"
+
+PYPI_PACKAGE = "yarl"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-idna \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}