aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-15 12:21:30 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-16 11:01:43 -0700
commit14f004c127d9065c7371e2c1c01f3ef3009736d1 (patch)
tree50a3e920170fed219912f4fa4ad647f2d1a79059 /meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb
parent9aabe2b4ee0d496a2f23cdc59221316b3d79107a (diff)
downloadmeta-openembedded-contrib-14f004c127d9065c7371e2c1c01f3ef3009736d1.tar.gz
python3-zeroconf: Add recipe
This is a pure Python multicast DNS service discovery library. Compatible with Bonjour/Avahi. Version 0.31.0 brings: - Separated cache loading from I/O in ServiceInfo and fixed cache lookup Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb b/meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb
new file mode 100644
index 0000000000..cb4c03329d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-zeroconf_0.31.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE = "https://github.com/jstasiak/python-zeroconf"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
+
+SRC_URI[sha256sum] = "53a180248471c6f81bd1fffcbce03ed93d7d8eaf10905c9121ac1ea996d19844"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ifaddr \
+"