aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorJohannes Pointner <johannes.pointner@br-automation.com>2017-10-31 14:09:08 +0100
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:32:15 -0800
commit28bf20899a7d45b6c3394191b45ad4625fd066c4 (patch)
treefdcbf003b0dd965c738a5f88bd5122100a41307a /meta-python/recipes-devtools/python
parentcfc43c30709a16286a3f56365351b26d44a1d62f (diff)
downloadmeta-openembedded-contrib-28bf20899a7d45b6c3394191b45ad4625fd066c4.tar.gz
python-pydbus: add new recipe
python-pydbus is a pythonic DBus library, which is one of the mentioned replacement of the deprecated python-dbus library (https://www.freedesktop.org/wiki/Software/DBusBindings) Signed-off-by: Johannes Pointner <johannes.pointner@br-automation.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pydbus.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-pydbus_0.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pydbus.inc b/meta-python/recipes-devtools/python/python-pydbus.inc
new file mode 100644
index 0000000000..0773b7ff88
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pydbus.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Pythonic DBus library"
+HOMEPAGE = "https://pypi.python.org/pypi/pydbus/"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a916467b91076e631dd8edb7424769c7"
+
+SRC_URI[md5sum] = "c6abd44862322679bd4e907bebc3e0d0"
+SRC_URI[sha256sum] = "4207162eff54223822c185da06c1ba8a34137a9602f3da5a528eedf3f78d0f2c"
+
+S = "${WORKDIR}/pydbus-${PV}"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-pygobject"
diff --git a/meta-python/recipes-devtools/python/python-pydbus_0.6.0.bb b/meta-python/recipes-devtools/python/python-pydbus_0.6.0.bb
new file mode 100644
index 0000000000..1722a80cd3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pydbus_0.6.0.bb
@@ -0,0 +1,2 @@
+require python-pydbus.inc
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
new file mode 100644
index 0000000000..7ed1c63b63
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
@@ -0,0 +1,2 @@
+require python-pydbus.inc
+inherit pypi setuptools3