aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-08-24 10:59:24 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:05 +0200
commit12e866c2cbbd2227cc6097400a10abfcdb5bb47a (patch)
tree4ff9959668d086b40881cd8874f250bbd0f41030 /meta-python/recipes-devtools/python
parent4d71753da9d11bf96e3d46cc74735188c3a7d7a2 (diff)
downloadmeta-openembedded-contrib-12e866c2cbbd2227cc6097400a10abfcdb5bb47a.tar.gz
python*-pylint: upgrade to v1.7.2 and fix qa error
Fix file-rdeps error about "#!/usr/bin/python" in python3-pylint by inheriting python*-dir so we can change to "#!/usr/bin/env ${PYTHON_PN}" in ${PYTHON_SITEPACKAGES_DIR}. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint.inc5
-rw-r--r--meta-python/recipes-devtools/python/python-pylint_1.7.2.bb (renamed from meta-python/recipes-devtools/python/python-pylint_1.6.5.bb)2
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb2
4 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc
index 18be8a1916..3ce1cae219 100644
--- a/meta-python/recipes-devtools/python/python-pylint.inc
+++ b/meta-python/recipes-devtools/python/python-pylint.inc
@@ -3,8 +3,8 @@ HOMEPAGE= "http://www.pylint.org/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
-SRC_URI[md5sum] = "31da2185bf59142479e4fa16d8a9e347"
-SRC_URI[sha256sum] = "a673984a8dd78e4a8b8cfdee5359a1309d833cf38405008f4a249994a8456719"
+SRC_URI[md5sum] = "27ee752cdcfacb05bf4940947e6b35c6"
+SRC_URI[sha256sum] = "ea6afb93a9ed810cf52ff3838eb3a15e2bf6a81b80de0eaede1ce442caa5ca69"
inherit pypi
@@ -28,4 +28,5 @@ from pylint import run_pylint
run_pylint()
EOF
chmod 755 ${D}${bindir}/pylint
+ sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript
}
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python-pylint_1.7.2.bb
index 47ab36a3ba..7b51d3fbd5 100644
--- a/meta-python/recipes-devtools/python/python-pylint_1.6.5.bb
+++ b/meta-python/recipes-devtools/python/python-pylint_1.7.2.bb
@@ -1,4 +1,4 @@
-inherit setuptools
+inherit setuptools python-dir
require python-pylint.inc
RDEPENDS_${PN} += "${PYTHON_PN}-backports-functools-lru-cache"
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb b/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
deleted file mode 100644
index fed65b3036..0000000000
--- a/meta-python/recipes-devtools/python/python3-pylint_1.6.5.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit setuptools3
-require python-pylint.inc
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb b/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb
new file mode 100644
index 0000000000..563e8316cf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint_1.7.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3 python3-dir
+require python-pylint.inc