aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-05-19 17:40:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:44 +0200
commitf68529c42cafe23fe20db07634f1437e31f472b6 (patch)
tree9fed5298e047dec294cb60c31e2e46eadf362ddd /meta-python/recipes-devtools/python
parent8c85e1a7d1a58f80497ab6546207abfe051987a4 (diff)
downloadmeta-openembedded-contrib-f68529c42cafe23fe20db07634f1437e31f472b6.tar.gz
python-sdnotify/python3-sdnotify: Add new recipe
python-sdnotify/python3-sdnotify is a pure python implementation for systemd's sd_notify mechanism. Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-sdnotify.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-sdnotify_0.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify_0.3.1.bb2
3 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sdnotify.inc b/meta-python/recipes-devtools/python/python-sdnotify.inc
new file mode 100644
index 0000000000..661ee6df97
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sdnotify.inc
@@ -0,0 +1,20 @@
+HOMEPAGE = "https://github.com/bb4242/sdnotify"
+SUMMARY = "A pure Python implementation of systemd's service notification protocol (sd_notify)"
+
+DESCRIPTION = "\
+ sdnotify is a pure Python implementation of the systemd sd_notify protocol. \
+ This protocol can be used to inform systemd about service start-up completion, \
+ watchdog events, and other service status changes. \
+ Thus, this package can be used to write system services in Python that play nicely with systemd. \
+ "
+
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e"
+
+SRC_URI[md5sum] = "a182c1ef47e1c6c965771aa3029da16f"
+SRC_URI[sha256sum] = "e69220d4f6cbb02130f43f929350a80cf51033fde47dcb056fbda71e2dff2d5a"
+
+do_install_append() {
+ rm -r ${D}/${datadir}
+}
diff --git a/meta-python/recipes-devtools/python/python-sdnotify_0.3.1.bb b/meta-python/recipes-devtools/python/python-sdnotify_0.3.1.bb
new file mode 100644
index 0000000000..39ae3fb0bd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sdnotify_0.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools pypi
+require python-sdnotify.inc
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.1.bb b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.1.bb
new file mode 100644
index 0000000000..377af12e16
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3 pypi
+require python-sdnotify.inc