aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-02-22 18:37:53 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-23 23:22:28 +0100
commit09a3bb6d4a02b452c9c9be38676a4ddcaae5008d (patch)
treec5ac1e6d83221e43d2a1310f6eb6f23ec219d360 /meta-python/recipes-devtools/python
parent4ebe225e20480e55a4b7044ebc440bd7322db1f5 (diff)
downloadmeta-openembedded-contrib-09a3bb6d4a02b452c9c9be38676a4ddcaae5008d.tar.gz
python-cloudeebus: remove obsolete recipe
The cloudeebus upstream project has not been active in 3.5 years and the current APIs for most of the dependencies have changed enough to not longer support the current implementation without pinning previous versions. Since this recipe has not functioned correctly for a while, remove it from the layer. Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-cloudeebus_0.6.0.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python-cloudeebus_0.6.0.bb b/meta-python/recipes-devtools/python/python-cloudeebus_0.6.0.bb
deleted file mode 100644
index 1490e2210b..0000000000
--- a/meta-python/recipes-devtools/python/python-cloudeebus_0.6.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "A component which enables calling DBus methods and registering on DBus signals from Javascript"
-HOMEPAGE = "https://github.com/01org/cloudeebus"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
-
-SRC_URI = "git://github.com/01org/cloudeebus.git;protocol=http;branch=master "
-SRCREV = "b5cc957eeabfe98cb996baf8e5a0ac848993c3d4"
-
-S = "${WORKDIR}/git"
-
-inherit distutils setuptools
-
-DEPENDS_${PN} = "python python-distribute"
-RDEPENDS_${PN} = "python python-dbus python-json python-argparse python-pygobject python-autobahn python-twisted python-subprocess"
-
-do_install_prepend() {
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}
-}
-
-DISTUTILS_INSTALL_ARGS = "--root=${D} \
- --single-version-externally-managed \
- --prefix=${prefix} \
- --install-lib=${PYTHON_SITEPACKAGES_DIR} \
- --install-data=${datadir}"
-
-do_install_append() {
- distutils_do_install
- install -d ${D}${datadir}/doc/${BPN}/
- install -m 0644 ${S}/README.md ${D}${datadir}/doc/${BPN}/
-}
-
-FILES_${PN} += "${datadir}/cloudeebus"
-FILES_${PN} += "${sysconfdir}/dbus-1/system.d/org.cloudeebus.conf"
-