aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-07-18 03:30:54 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:52 +0200
commit1e6c70dd042b72727e974519ff49b68820305718 (patch)
treeef0b0f833abe1040ac4953c945789f30051c61d5 /meta-python/recipes-devtools/python
parent7c550fd3008eb2edc443b212084ab4d744e0275b (diff)
downloadmeta-openembedded-contrib-1e6c70dd042b72727e974519ff49b68820305718.tar.gz
python-unidiff: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-unidiff.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-unidiff_0.5.4.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-unidiff_0.5.4.bb2
3 files changed, 13 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-unidiff.inc b/meta-python/recipes-devtools/python/python-unidiff.inc
new file mode 100644
index 0000000000..0402550915
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-unidiff.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Unified diff parsing/metadata extraction library"
+HOMEPAGE = "http://github.com/matiasb/python-unidiff"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
+
+SRC_URI[md5sum] = "c8099edf89d2e3bac16123766625a38b"
+SRC_URI[sha256sum] = "a7baf71846a68c5305a7d6005dfb5eca8798f13861176355a285cbda3206824d"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-unidiff_0.5.4.bb b/meta-python/recipes-devtools/python/python-unidiff_0.5.4.bb
index ceb80bdd37..bdb3d27f9a 100644
--- a/meta-python/recipes-devtools/python/python-unidiff_0.5.4.bb
+++ b/meta-python/recipes-devtools/python/python-unidiff_0.5.4.bb
@@ -1,9 +1,2 @@
-SUMMARY = "Unified diff parsing/metadata extraction library"
-HOMEPAGE = "http://github.com/matiasb/python-unidiff"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
-
-SRC_URI[md5sum] = "c8099edf89d2e3bac16123766625a38b"
-SRC_URI[sha256sum] = "a7baf71846a68c5305a7d6005dfb5eca8798f13861176355a285cbda3206824d"
-
-inherit pypi setuptools
+require python-unidiff.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-unidiff_0.5.4.bb b/meta-python/recipes-devtools/python/python3-unidiff_0.5.4.bb
new file mode 100644
index 0000000000..0ddc7e2f20
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-unidiff_0.5.4.bb
@@ -0,0 +1,2 @@
+require python-unidiff.inc
+inherit setuptools3