aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-08-25 15:46:27 +1200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:06 +0200
commit2951fb898e7c761e3071521b58c9aa6cc746fba3 (patch)
treebf540985c306b95fbfc6387d2ca9710665902e1c /meta-python/recipes-devtools/python
parentf968e5c774f0d19eec51bf60fb2866b62aa2ce58 (diff)
downloadmeta-openembedded-contrib-2951fb898e7c761e3071521b58c9aa6cc746fba3.tar.gz
python-paho-mqtt: fix downloading during do_compile
During do_compile if setup.py finds that pytest-runner - which is declared as a setup dependency in setup.py - isn't available it was attempting to download it from pypi, which is problematic if you are behind a proxy because the environment for do_compile isn't set up for that. Add an appropriate native dependency to prevent this situation. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
index 6cbde74cb4..ad1ce6a90f 100644
--- a/meta-python/recipes-devtools/python/python-paho-mqtt.inc
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
@@ -10,6 +10,8 @@ inherit pypi
SRC_URI[md5sum] = "b9338236e2836e8579ef140956189cc4"
SRC_URI[sha256sum] = "2c9ef5494cfc1e41a9fff6544c5a2cd59ea5d401d9119a06ecf7fad6a2ffeb93"
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
RDEPENDS_${PN} = "\
${PYTHON_PN}-math \
${PYTHON_PN}-io \