aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-15 15:06:47 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:39 +0200
commit795dc3f0e3af3c98cad000852d57779f6605882f (patch)
tree03b86be507ae9283e2ccbf899c307da78d86ea1c /meta-python/recipes-devtools/python
parentac2336f83f7044e17cfc9f8230a3f8a81fca8c6d (diff)
downloadmeta-openembedded-contrib-795dc3f0e3af3c98cad000852d57779f6605882f.tar.gz
python-django: update to version 1.9.7 and add the required RDEPENDS
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.8.8.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.9.7.bb24
2 files changed, 24 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-django_1.8.8.bb b/meta-python/recipes-devtools/python/python-django_1.8.8.bb
deleted file mode 100644
index e56c55558d..0000000000
--- a/meta-python/recipes-devtools/python/python-django_1.8.8.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "A high-level Python Web framework"
-HOMEPAGE = "http://www.djangoproject.com/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
-
-SRC_URI[md5sum] = "08ecf83b7e9d064ed7e3981ddc3a8a15"
-SRC_URI[sha256sum] = "8255242fa0d9e0bf331259a6bdb81364933acbe8863291661558ffdb2fc9ed70"
-
-PYPI_PACKAGE = "Django"
-inherit pypi setuptools
-
-FILES_${PN} += "${datadir}/django"
-
-BBCLASSEXTEND = "nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-django_1.9.7.bb b/meta-python/recipes-devtools/python/python-django_1.9.7.bb
new file mode 100644
index 0000000000..8693da8b15
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-django_1.9.7.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A high-level Python Web framework"
+HOMEPAGE = "http://www.djangoproject.com/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
+
+SRC_URI[md5sum] = "7de9ba83bfe01f4b7d45645c1b259c83"
+SRC_URI[sha256sum] = "2b29e81c8c32b3c0d9a0119217416887c480d927ae2630bada2da83078c93bf6"
+
+PYPI_PACKAGE = "Django"
+inherit pypi setuptools
+
+FILES_${PN} += "${datadir}/django"
+
+BBCLASSEXTEND = "nativesdk"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-importlib \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pip \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+ "