aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-03-25 18:48:18 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-01 15:33:55 +0200
commitce933d4db45a7361f24b7d31e4782c847cfea3eb (patch)
tree8e13d14dd9eabf9e099bf76bf970277d408b41cd /meta-python/recipes-devtools/python
parent306e42cd6860589d5f96da628add17a3dcaf81c3 (diff)
downloadmeta-openembedded-contrib-ce933d4db45a7361f24b7d31e4782c847cfea3eb.tar.gz
python-pymisp: update to 2.3
Signed-off-by: Derek Straka <derek@asterius.io>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pymisp.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pymisp_2.3.bb (renamed from meta-python/recipes-devtools/python/python-pymisp_2.2.bb)2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.3.bb (renamed from meta-python/recipes-devtools/python/python3-pymisp_2.2.bb)2
3 files changed, 5 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymisp.inc b/meta-python/recipes-devtools/python/python-pymisp.inc
index ca543f0ef6..9cd0844131 100644
--- a/meta-python/recipes-devtools/python/python-pymisp.inc
+++ b/meta-python/recipes-devtools/python/python-pymisp.inc
@@ -1,14 +1,10 @@
DESCRIPTION = "Python API for MISP"
HOMEPAGE = "https://github.com/MISP/PyMISP"
-SECTION = "devel/python"
LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
-SRCREV = "a7fc1ceb20d455ccfa2ba7af229048330e22b173"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=c0a3e801b740ef31d1f5ddfe76bca538"
PR = "r0"
-SRC_URI = "git://github.com/MISP/PyMISP.git;branch=master"
-
-SRCNAME = "pymisp"
-S = "${WORKDIR}/git"
+SRC_URI[md5sum] = "398408388902c108e3b378152b6c1d24"
+SRC_URI[sha256sum] = "d70e74c528f040f5ff8137337f1758aeb63a5966b58b297f2171f53cb9df033e"
RDEPENDS_${PN} += " ${PYTHON_PN}-requests"
diff --git a/meta-python/recipes-devtools/python/python-pymisp_2.2.bb b/meta-python/recipes-devtools/python/python-pymisp_2.3.bb
index a0b655fbd1..1b1fbe956e 100644
--- a/meta-python/recipes-devtools/python/python-pymisp_2.2.bb
+++ b/meta-python/recipes-devtools/python/python-pymisp_2.3.bb
@@ -1,2 +1,2 @@
-inherit setuptools
+inherit pypi setuptools
require python-pymisp.inc
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.2.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.3.bb
index e41acd6249..4523d9e30a 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.3.bb
@@ -1,2 +1,2 @@
-inherit setuptools3
+inherit pypi setuptools3
require python-pymisp.inc