aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:21:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:15 +0100
commitedae1715d7d0090672b32a5a2e484852764d6c57 (patch)
tree6347ffbe05ac96afd43fae8d0c6f1b92f8fc9ec2 /meta-python/recipes-devtools/python
parentabc0ec53987b67f07ab64ce4dbd0573cc3d4bd1b (diff)
downloadmeta-openembedded-contrib-edae1715d7d0090672b32a5a2e484852764d6c57.tar.gz
python(3)-itsdangerous: add recipes
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-itsdangerous.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-itsdangerous.inc b/meta-python/recipes-devtools/python/python-itsdangerous.inc
new file mode 100644
index 0000000000..73951fa561
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-itsdangerous.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Various helpers to pass trusted data to untrusted environments and back."
+HOMEPAGE = "http://github.com/mitsuhiko/itsdangerous"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b61841e2bf5f07884148e2a6f1bcab0c"
+
+SRC_URI[md5sum] = "a3d55aa79369aef5345c036a8a26307f"
+SRC_URI[sha256sum] = "cbb3fcf8d3e33df861709ecaf89d9e6629cff0a217bc2848f1b41cd30d360519"
+
+CLEANBROKEN = "1"
diff --git a/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
new file mode 100644
index 0000000000..350925df0a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-itsdangerous_0.24.bb
@@ -0,0 +1,2 @@
+inherit pypi
+require python-itsdangerous.inc
diff --git a/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb b/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb
new file mode 100644
index 0000000000..8c791ccb16
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-itsdangerous_0.24.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-itsdangerous.inc