aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-02-08 16:08:34 +0800
committerKhem Raj <raj.khem@gmail.com>2023-02-08 08:51:44 -0800
commit5df692b1b515fb45e7f0b65659b32420f5d67f02 (patch)
tree0b91ccd7d8e515fcd6760617896e977a8e5f8bd4 /meta-python/recipes-devtools/python
parent585e4da5ab391c859dc0371f5cc0420e5c823a27 (diff)
downloadmeta-openembedded-contrib-5df692b1b515fb45e7f0b65659b32420f5d67f02.tar.gz
python3-aspectlib: upgrade 1.5.2 -> 2.0.0
License-Update: Copyright updated to 2022. 0001-Remove-tornado-6-test-constraint.-Ref-15.patch removed since it's not available in 2.0.0. Changelog: ========= Drop support for legacy Pythons (2.7, 3.6 or older). Remove Travis/Appveyor CI and switch to GitHub Actions. Added support for Tornado 6 (in the test suite). Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch45
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb)5
2 files changed, 2 insertions, 48 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch b/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch
deleted file mode 100644
index 174f088e9e..0000000000
--- a/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From d3ae6ac951cc5bbce29b9c987741e0a557c9b777 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ionel=20Cristian=20M=C4=83rie=C8=99?= <contact@ionelmc.ro>
-Date: Sun, 2 May 2021 09:50:43 +0300
-Subject: [PATCH] Remove tornado<6 test constraint. Ref #15.
-
-Upstream-Status: Backport [https://github.com/ionelmc/python-aspectlib/commit/7dccb198dfb426f529b81a28a755f3c02f8b50cb]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/test_integrations_py3.py | 5 ++++-
- tox.ini | 3 ++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_integrations_py3.py b/tests/test_integrations_py3.py
-index e025eac..596589d 100644
---- a/tests/test_integrations_py3.py
-+++ b/tests/test_integrations_py3.py
-@@ -36,7 +36,10 @@ def test_decorate_tornado_coroutine():
- @gen.coroutine
- @debug.log(print_to=buf, module=False, stacktrace=2, result_repr=repr)
- def coro():
-- yield gen.Task(loop.add_timeout, timedelta(microseconds=10))
-+ if hasattr(gen, 'Task'):
-+ yield gen.Task(loop.add_timeout, timedelta(microseconds=10))
-+ else:
-+ yield gen.sleep(0.01)
- return "result"
-
- loop = ioloop.IOLoop.current()
-diff --git a/tox.ini b/tox.ini
-index 8c607de..08c31b3 100644
---- a/tox.ini
-+++ b/tox.ini
-@@ -55,7 +55,8 @@ deps =
- pytest-clarity
- pytest-cov
- pytest-travis-fold
-- tornado<6.0
-+ six
-+ tornado
- commands =
- {posargs:pytest --cov --cov-report=term-missing -vv --ignore=src}
-
---
-2.32.0
-
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb
index 71f3d3594e..416b031c5e 100644
--- a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb
@@ -6,14 +6,13 @@ DESCRIPTION = " It is useful when changing behavior in existing code is desired.
It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework."
HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=80721ace117fd1f814049ecb81c6be76"
-SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
+SRC_URI[sha256sum] = "a4b461b9da0b531aebcb93efcde3de808a72c60226dd8d902c467d13faf7ce92"
inherit ptest pypi setuptools3
SRC_URI += "file://run-ptest \
- file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
"
do_install_ptest() {