aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-08-26 11:19:44 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-27 13:08:27 -0700
commit1b358be2b88eb78b557fbb2479321c2fdcbac9e0 (patch)
tree0978e6a0011f4bc71050d167127d7e4aba6be9c0 /meta-python/recipes-devtools/python
parent8d62db72656a76c198b43783dfbe530c6bdea382 (diff)
downloadmeta-openembedded-contrib-1b358be2b88eb78b557fbb2479321c2fdcbac9e0.tar.gz
python3-license-expression: add ptest artifacts
The python3-license-expression ptest is failing because it requires the contents of the src/ directory from the repo/tarball. Copy this content to the image when installing the ptest so that it has what it needs. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
index 2ed5d91709..efa8854411 100644
--- a/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
+++ b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
@@ -28,6 +28,8 @@ RDEPENDS:${PN}-ptest += " \
"
do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests
+ install -d ${D}${PTEST_PATH}/src
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
}