aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-23 13:14:24 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-22 22:20:42 -0700
commit556ceafff48fea3f031c44c88cee9ed8a881647d (patch)
treed74a0561f33ec2ea3921a277a3c197229622dfd1 /meta-python/recipes-devtools/python
parentdb563ff70a5218cee1f5e84d76f2f8d59c210b43 (diff)
downloadmeta-openembedded-contrib-556ceafff48fea3f031c44c88cee9ed8a881647d.tar.gz
python3-typeguard: upgrade 2.13.3 -> 3.0.1
Changelog: ========== Improved the documentation Fixed assignment unpacking (a, b = ...) being checked incorrectly Fixed @typechecked attempting to instrument wrapper decorators such as @contextmanager when applied to a class Fixed py.typed missing from the wheel when not building from a git checkout BACKWARD INCOMPATIBLE Dropped the argname, memo, globals and locals arguments from check_type() BACKWARD INCOMPATIBLE Removed the check_argument_types() and check_return_type() functions (use @typechecked instead) BACKWARD INCOMPATIBLE Moved install_import_hook to be directly importable from the typeguard module BACKWARD INCOMPATIBLE Changed the checking of collections (list, set, dict, sequence, mapping) to only check the first item by default. BACKWARD INCOMPATIBLE Type checking failures now raise typeguard.TypeCheckError instead of TypeError Dropped Python 3.5 and 3.6 support Dropped the deprecated profiler hook (TypeChecker) Added a configuration system Added support for custom type checking functions Added support for PEP 604 union types (X | Y) on all Python versions Added support for generic built-in collection types (list[int] et al) on all Python versions Added support for checking arbitrary Mapping types Added support for the Self type Added support for typing.Never (and typing_extensions.Never) Added support for Never and NoReturn in argument annotations Added support for LiteralString Added support for TypeGuard Added support for the subclassable Any on Python 3.11 and typing_extensions Added the possibility to have the import hook instrument all packages Added the suppress_type_checks() context manager function for temporarily disabling type checks Much improved error messages showing where the type check failed Made it possible to apply @typechecked on top of @classmethod / @staticmethod (PR by jacobpbrugh) Changed check_type() to return the passed value, so it can be used (to an extent) in place of typing.cast(), but with run-time type checking Replaced custom implementation of is_typeddict() with the implementation from typing_extensions v4.1.0 Emit InstrumentationWarning instead of raising RuntimeError from the pytest plugin if modules in the target package have already been imported Fixed TypeError when checking against TypedDict when the value has mixed types among the extra keys (PR by biolds) Fixed incompatibility with typing_extensions v4.1+ on Python 3.10 (PR by David C.) Fixed checking of Tuple[()] on Python 3.11 and tuple[()] on Python 3.9+ Fixed integers 0 and 1 passing for Literal[False] and Literal[True], respectively Fixed type checking of annotated variable positional and keyword arguments (*args and **kwargs) Fixed checks against unittest.Mock and derivatives being done in the wrong place Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_3.0.1.bb (renamed from meta-python/recipes-devtools/python/python3-typeguard_2.13.3.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.13.3.bb b/meta-python/recipes-devtools/python/python3-typeguard_3.0.1.bb
index e9fce61452..932b6f0c6d 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_2.13.3.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_3.0.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://pypi.org/project/typeguard/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
-SRC_URI[sha256sum] = "00edaa8da3a133674796cf5ea87d9f4b4c367d77476e185e80251cc13dfbb8c4"
+SRC_URI[sha256sum] = "beb0e67c5dc76eea4a6d00a6606d444d899589908362960769d0c4a1d32bca70"
inherit pypi python_setuptools_build_meta ptest