aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:42 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c (patch)
treeefd62458ef4652877d2f8482b4c2133d2c3d0fa3 /meta-python/recipes-devtools/python
parentbecd9ec57a7b38279ea79708f583a5b2eba3f30d (diff)
downloadmeta-openembedded-contrib-6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c.tar.gz
python3-eth-utils: new package
Add a recipe for eth-utils: utility functions for codebases which interact with ethereum. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch37
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb16
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch
new file mode 100644
index 0000000000..3c3c5270a3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch
@@ -0,0 +1,37 @@
+From bc86d603e632ce61de4ae7a5d4bcef080cbdb160 Mon Sep 17 00:00:00 2001
+From: Bartosz Golaszewski <brgl@bgdev.pl>
+Date: Wed, 11 May 2022 13:45:06 +0200
+Subject: [PATCH] setup: don't use setuptools-markdown
+
+This project is deprecated and irrelevant for the functionality of
+eth-utils. We don't support it in meta-python so just drop it from
+the dependencies.
+
+Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
+---
+ setup.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 5717d5b..cb62132 100644
+--- a/setup.py
++++ b/setup.py
+@@ -37,7 +37,6 @@ setup(
+ # *IMPORTANT*: Don't manually change the version here. Use the 'bumpversion' utility.
+ version='1.1.2',
+ description="""Common utility functions for ethereum codebases.""",
+- long_description_markdown_filename='README.md',
+ author='Piper Merriam',
+ author_email='pipermerriam@gmail.com',
+ url='https://github.com/ethereum/eth_utils',
+@@ -48,7 +47,6 @@ setup(
+ "toolz>0.8.2,<1;implementation_name=='pypy'",
+ "cytoolz>=0.8.2,<1.0.0;implementation_name=='cpython'",
+ ],
+- setup_requires=['setuptools-markdown'],
+ extras_require=extras_require,
+ py_modules=['eth_utils'],
+ license="MIT",
+--
+2.34.1
+
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
new file mode 100644
index 0000000000..ff7caf5bf2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Common utility functions for codebases which interact with ethereum."
+HOMEPAGE = "https://github.com/ethereum/eth-utils"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=287820ad3553117aa2f92bf84c219324"
+
+SRC_URI[sha256sum] = "32f50edb14c5be0c4f0e8c2e6117286ccc5dfda21d170f358add554a048398e3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-eth-hash \
+ python3-eth-typing \
+ python3-setuptools \
+ python3-toolz \
+"