aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorVesa Jääskeläinen <vesa.jaaskelainen@vaisala.com>2021-08-28 18:44:29 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-30 08:10:12 -0700
commit78922a3621fd63b064e2fa14bae70588ad4de0c1 (patch)
tree5206116e129b9320c4bd4ddd0d4fb46aa1d755fe /meta-python/recipes-devtools/python
parentf3df549ef6eb3525a4c902fcb502d54849e5fec5 (diff)
downloadmeta-openembedded-contrib-78922a3621fd63b064e2fa14bae70588ad4de0c1.tar.gz
python3-cached-property: Add recipe for version 1.5.2
"A decorator for caching properties in classes." Signed-off-by: Vesa Jääskeläinen <vesa.jaaskelainen@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cached-property_1.5.2.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cached-property_1.5.2.bb b/meta-python/recipes-devtools/python/python3-cached-property_1.5.2.bb
new file mode 100644
index 0000000000..059c34a29d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cached-property_1.5.2.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A decorator for caching properties in classes."
+DESCRIPTION = "Makes caching of time or computational expensive properties quick and easy."
+HOMEPAGE = "https://pypi.org/project/cached-property/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=db7ff60c4e14f58534201242803d8abc"
+
+SRC_URI[sha256sum] = "9fa5755838eecbb2d234c3aa390bd80fbd3ac6b6869109bfc1b499f7bd89a130"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"