aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-16 14:45:53 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-16 09:09:47 -0700
commit9de3008c5a2f2f919e87ed97adea063edc19be82 (patch)
tree7330397691d8220325bac383f7e8e3c66bafd7de /meta-python/recipes-devtools/python
parent72fbb8379fc47ec77cdcb1c15e992d99d205ced2 (diff)
downloadmeta-openembedded-contrib-9de3008c5a2f2f919e87ed97adea063edc19be82.tar.gz
python3-inotify: new package
We have a recipe for python3-pyinotify (not to be confused with the recently added python3-pyfanotify) but this project has been abandoned years ago. There's another - still maintained - project called simply inotify on pypi and this adds the recipe for it. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb b/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb
new file mode 100644
index 0000000000..524c3a0d29
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb
@@ -0,0 +1,14 @@
+SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
+AUTHOR = "Dustin Oprea"
+HOMEPAGE = "https://pypi.org/project/inotify/"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
+
+SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-ctypes \
+ python3-logging \
+"