aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorzhengrq.fnst <zhengrq.fnst@fujitsu.com>2022-05-12 17:19:14 +0800
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commitb035f0271585f3664282cb71caad9928a1d424d2 (patch)
tree36e48946ea9d648568f4df298784a0274b0c0af4 /meta-python/recipes-devtools/python
parenta4c38d5910b066c05f3bfff23230aabb4c4d74af (diff)
downloadmeta-openembedded-contrib-b035f0271585f3664282cb71caad9928a1d424d2.tar.gz
python3-bitarray: upgrade 2.4.1 -> 2.5.0
2022-05-04 2.5.0: ------------------- * add calculating of canonical Huffman codes 'util.canonical_huffman()' and decoding thereof 'util.canonical_decode()', see #173 * allow creating "Huffman codes" from frequency maps with a single symbol in 'util.huffman_code()' and 'util.canonical_huffman()', see #172 * allow bytes-like argument in '.frombytes()' and '.pack()' - previously, the arguments were limited to the 'bytes' object, see #174 * allow bytes-like arguments in 'util.deserialize()' * add official pyodide support * add [DEFLATE decompression](../examples/puff/) example * optimize '.bytereverse()' * optimize 'delslice()' for cases like 'del a[1:17:2]' when 'a' is large * fix 'examples/huffman/compress.py' to handle files with 0 or 1 characters, see also #172 * add 'skipIF' decorator for skipping tests * add test Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb b/meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb
index fbb89b8dd7..bb80c4a04f 100644
--- a/meta-python/recipes-devtools/python/python3-bitarray_2.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-bitarray_2.5.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/ilanschnell/bitarray"
LICENSE = "PSF-2.0"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=2ad702cdcd49e8d2ac01d7e7d0810d2d"
-SRC_URI[sha256sum] = "faeca03f979e992cc76f7406af7eb9795cb111b8d8969c891a032bd7497c87da"
+SRC_URI[sha256sum] = "5abed04adcd2031f6e714993d95223bf9ae85354c640c270b2ed6f46b83573ba"
inherit setuptools3 pypi