aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:37 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commitcbe064cb6e53ed83a66141775ffb3132b81b0bdf (patch)
treecdb706416c9e33e545763689ed50ed4ca711cb00 /meta-python/recipes-devtools/python
parentc06c5b71eefaa29c5d1b0f3b3cdcfb03663e4d75 (diff)
downloadmeta-openembedded-contrib-cbe064cb6e53ed83a66141775ffb3132b81b0bdf.tar.gz
python3-toolz: new package
Add a recipe for toolz: a set of utility functions for iterators, functions, and dictionaries. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb b/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb
new file mode 100644
index 0000000000..a597641e50
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A set of utility functions for iterators, functions, and dictionaries."
+HOMEPAGE = "https://github.com/pytoolz/toolz"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ca09cab178326d18433aae982d1edf5d"
+
+SRC_URI[sha256sum] = "6b312d5e15138552f1bda8a4e66c30e236c831b612b2bf0005f8a1df10a4bc33"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-json \
+ python3-math \
+"