aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-10 17:08:25 +0100
committerKhem Raj <raj.khem@gmail.com>2018-07-12 07:19:43 -0700
commit9f292d50183baa1951dc2ff3b9b691852b89eadb (patch)
treecfca2ecff81494d99b2b520cda4b0c80bd682a9e /meta-python/recipes-devtools
parent40716b97d84d96bb13dc7f46afbdbf36b511be84 (diff)
downloadmeta-openembedded-contrib-9f292d50183baa1951dc2ff3b9b691852b89eadb.tar.gz
python-stevedore: add Py2 and Py3 recipes for stevedore
Based on a recipe from meta-openstack, but with the rmargparse class removed (which doesn't appear to be needed anymore) and Python 3 support added. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-stevedore.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-stevedore_1.28.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-stevedore_1.28.0.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-stevedore.inc b/meta-python/recipes-devtools/python/python-stevedore.inc
new file mode 100644
index 0000000000..b23fb4c8c5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-stevedore.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Manage dynamic plugins for Python applications"
+HOMEPAGE = "https://github.com/dreamhost/stevedore"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "b736a71431a2ff5831bbff4a6ccec0c1"
+SRC_URI[sha256sum] = "f1c7518e7b160336040fee272174f1f7b29a46febb3632502a8f2055f973d60b"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-stevedore_1.28.0.bb b/meta-python/recipes-devtools/python/python-stevedore_1.28.0.bb
new file mode 100644
index 0000000000..70a00c1315
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-stevedore_1.28.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-stevedore.inc
diff --git a/meta-python/recipes-devtools/python/python3-stevedore_1.28.0.bb b/meta-python/recipes-devtools/python/python3-stevedore_1.28.0.bb
new file mode 100644
index 0000000000..3f557f2cbf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-stevedore_1.28.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-stevedore.inc