aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorPeter Kolbus <peter.kolbus@garmin.com>2020-01-02 12:37:42 -0600
committerKhem Raj <raj.khem@gmail.com>2020-01-02 19:29:25 -0800
commit8cb441b64045bb2edddf46b5d6b0c0713cbc55a0 (patch)
tree9f40da1e8b14594736ca462ab7f6f6b8214cf86c /meta-python/recipes-devtools
parente6cebf9e01232562da8e27b074fbbfe7aa66a5d2 (diff)
downloadmeta-openembedded-contrib-8cb441b64045bb2edddf46b5d6b0c0713cbc55a0.tar.gz
python3-booleanpy: add recipe
boolean.py is a library to define and parse boolean algebras. It is used by python3-license-expression. Signed-off-by: Peter Kolbus <peter.kolbus@garmin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-booleanpy.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-booleanpy.inc b/meta-python/recipes-devtools/python/python-booleanpy.inc
new file mode 100644
index 0000000000..335d7d396d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-booleanpy.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
new file mode 100644
index 0000000000..5f8602d187
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-booleanpy_3.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-booleanpy.inc