aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorPeter Kolbus <peter.kolbus@garmin.com>2019-12-29 10:11:24 -0600
committerKhem Raj <raj.khem@gmail.com>2019-12-29 23:04:31 -0800
commitb18f944e9eb5e81054bcbdab2c68303f041381cc (patch)
treea1362cdcc735db0efd8f4d55a5bf089416b925f5 /meta-python/recipes-devtools
parent1ec35f4dccd31096951b7c3bfd4fdfac85f76022 (diff)
downloadmeta-openembedded-contrib-b18f944e9eb5e81054bcbdab2c68303f041381cc.tar.gz
python3-html2text: add recipe
python3-html2text converts HTML to Markdown-formatted text. Signed-off-by: Peter Kolbus <peter.kolbus@garmin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-html2text.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-html2text_2019.8.11.bb2
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-html2text.inc b/meta-python/recipes-devtools/python/python-html2text.inc
new file mode 100644
index 0000000000..678dcef3f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-html2text.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Convert HTML to Markdown-formatted text"
+HOMEPAGE = "https://github.com/Alir3z4/html2text"
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI[md5sum] = "21aad7ec95b70606024b783c8253899c"
+SRC_URI[sha256sum] = "f516b9c10284174e2a974d86f91cab02b3cf983a17752075da751af0e895ef5e"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-html2text_2019.8.11.bb b/meta-python/recipes-devtools/python/python3-html2text_2019.8.11.bb
new file mode 100644
index 0000000000..9cb5b01eba
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-html2text_2019.8.11.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-html2text.inc