aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-01 12:41:24 -0400
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:31 -0800
commit2b6ae2d951df1050bf4fe0734ece750d0fef2faf (patch)
treed4f39f8b20316463039d445e3d2706fcfff7fcae /meta-python/recipes-devtools
parentbd827cb9ff57b8e42768add8e8b206c95cd6aea2 (diff)
downloadmeta-openembedded-contrib-2b6ae2d951df1050bf4fe0734ece750d0fef2faf.tar.gz
python-automat: add an initial recipe for version 0.6.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-automat.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-automat_0.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-automat_0.6.0.bb4
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat.inc b/meta-python/recipes-devtools/python/python-automat.inc
new file mode 100644
index 0000000000..1ac5d3b323
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-automat.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Self-service finite-state machines for the programmer on the go"
+HOMEPAGE = "https://github.com/glyph/Automat"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+
+SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
+SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
+
+PYPI_PACKAGE = "Automat"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-six \
+"
diff --git a/meta-python/recipes-devtools/python/python-automat_0.6.0.bb b/meta-python/recipes-devtools/python/python-automat_0.6.0.bb
new file mode 100644
index 0000000000..8ac8c9c0ff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-automat_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-automat.inc
diff --git a/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb
new file mode 100644
index 0000000000..0469e61380
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb
@@ -0,0 +1,4 @@
+inherit setuptools3
+require python-automat.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-enum "