aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-02-01 14:23:40 +0000
committerArmin Kuster <akuster808@gmail.com>2018-02-11 12:01:54 -0800
commit69fdb96e9b41ac5211ed9b21d2249202fd0853a8 (patch)
treea01fe6880765cdb89a47acca5babf17294e0d92b /meta-python/recipes-devtools
parentcf4161777141c20a811113a5ad3216248bfa6412 (diff)
downloadmeta-openembedded-contrib-69fdb96e9b41ac5211ed9b21d2249202fd0853a8.tar.gz
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs: require pam in DISTRO_FEATURES
* there is explicit dependency on libpam without respecting pam in DISTRO_FEATURES so add the check to prevent people building it against broken libpam Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pam_1.8.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
index 05bddd527b..60a3b43de5 100644
--- a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
+++ b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
@@ -10,3 +10,6 @@ PYPI_PACKAGE = "python-pam"
inherit pypi setuptools
RDEPENDS_${PN} = "libpam"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "pam"