aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:43 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit5ba8fdacdb7480f6f44d328294a7c7a3d034cc9c (patch)
treef5923aada3806ae03c15f4f5c94a485d42cf2cd9 /meta-python/recipes-devtools
parent6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c (diff)
downloadmeta-openembedded-contrib-5ba8fdacdb7480f6f44d328294a7c7a3d034cc9c.tar.gz
python3-eth-keys: new package
Add a recipe for eth-keys: common API for Ethereum key operations. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb b/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb
new file mode 100644
index 0000000000..b0b1aad76d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb
@@ -0,0 +1,11 @@
+SUMMARY = "A common API for Ethereum key operations with pluggable backends."
+HOMEPAGE = "https://github.com/ethereum/eth-keys"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2beaef1b1764f4d6b46084c885b4bcad"
+
+SRC_URI[sha256sum] = "7d18887483bc9b8a3fdd8e32ddcb30044b9f08fcb24a380d93b6eee3a5bb3216"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-eth-utils"