aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-05-01 09:14:36 -0700
committerKhem Raj <raj.khem@gmail.com>2022-05-02 14:12:13 -0700
commite347168b10a69febd106d758faf20d95c4bd8b62 (patch)
treec25519e44fc537abf9c12666ddf842b76e0ae4e5 /meta-python/recipes-devtools
parent91f01ce558e27dea6c5307d58a0426f5ca54fa58 (diff)
downloadmeta-openembedded-contrib-e347168b10a69febd106d758faf20d95c4bd8b62.tar.gz
python3-wxgtk4: Needs x11 for sip module
sip/cpp/sip_corewxWindow.cpp requires gdk/gdkx.h which wont be built when gtk is built without x11, therefore require x11 when building this recipe, if gdkx.h is removed form includes then it fails ../../../../sip/cpp/sip_corewxWindow.cpp:56:16: error: unknown type name 'XID' static XID GetXWindow(const wxWindow* wxwin) { ^ ../../../../sip/cpp/sip_corewxWindow.cpp:59:28: error: use of undeclared identifier 'GDK_WINDOW_XID' return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_wxwindow)); ^ ../../../../sip/cpp/sip_corewxWindow.cpp:64:28: error: use of undeclared identifier 'GDK_WINDOW_XID' return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_widget)); ^ so it is using it and will need some work to get it going without x11 until then disable building it on non-x11 distros Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index 3583acc9cd..6ec92c2cec 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/wxPython-${PV}"
inherit pypi setuptools3 pkgconfig features_check
-ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "x11"
export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"