aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-04-22 12:59:42 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:36 +0200
commit85c72f42f4db8543755a6be97b41bd2df921f593 (patch)
tree40097d16f3c3ba4f02ea1a2d0fa1455477467094 /meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
parentd95712f0fa8218fb1995bf88634e4493a16acbab (diff)
downloadmeta-openembedded-contrib-85c72f42f4db8543755a6be97b41bd2df921f593.tar.gz
python-parted: update to version 3.10.7
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
new file mode 100644
index 0000000000..712c4b97ab
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "pyparted is a set of Python modules that provide Python programmers \
+an interface to libparted, the GNU parted library for disk partitioning and \
+filesystem manipulation."
+SUMMARY = "Python bindings for libparted"
+HOMEPAGE = "https://github.com/rhinstaller/pyparted"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "\
+ file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
+ file://src/_pedmodule.c;startline=10;endline=22;md5=ebcb25dde1ac9c46e986dec79b404e7e \
+"
+DEPENDS += "parted python-re"
+
+PV = "3.10.7+git${SRCPV}"
+
+# upstream only publishes releases in github archives which are discouraged
+SRCREV = "69c4a478e43d3eff6ae3a0116fa38da06776d5f5"
+SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https \
+ file://0001-fix-version-float-check.patch \
+"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND += "native"