aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-03-04 17:41:00 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-09 07:37:04 -0800
commit34d4ce1d5b5c2148307a9c60467dbd122501b3db (patch)
tree778c61c549e8dfef2b992b8c7c8f5b0e7c3d7cfc /meta-python/recipes-extended
parent56c3d5dfb1cc3af8bd074511ca128ac53e26d38e (diff)
downloadmeta-openembedded-contrib-34d4ce1d5b5c2148307a9c60467dbd122501b3db.tar.gz
python3-blivet: use setuptools_legacy
The setup.py installs to arbitrary target paths, so can't use the new bdist_wheel installation method. Reverts daba6521f which was a sympton of the bad usage. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
index fcadf130c9..bd57604f26 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
@@ -19,16 +19,10 @@ SRC_URI += "\
"
SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48"
-inherit pypi features_check systemd setuptools3
+inherit pypi features_check systemd setuptools3_legacy
REQUIRED_DISTRO_FEATURES = "systemd"
-do_install:append() {
- mv ${D}${PYTHON_SITEPACKAGES_DIR}${exec_prefix}/* ${D}${exec_prefix}
- mv ${D}${PYTHON_SITEPACKAGES_DIR}${sysconfdir} ${D}
- mv ${D}${PYTHON_SITEPACKAGES_DIR}${base_libdir} ${D}
-}
-
RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
parted python3-pyparted multipath-tools \
lsof cryptsetup libblockdev \