aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-02 19:55:02 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:07 -0800
commitdaba6521fa5a8baa1bd53312d025982e201d022a (patch)
tree061d5e67b1e9d3bee43c6009cc4fc90fed9b54d0 /meta-python/recipes-extended
parentb879b58b8647ffe7c452bd875f8e610871ae8334 (diff)
downloadmeta-openembedded-contrib-daba6521fa5a8baa1bd53312d025982e201d022a.tar.gz
python3-blivet: Adjust install location for binaries and systemd units
With wheels changes it is also getting installed under PYTHON_SITEPACKAGES_DIR perhaps something to fix in setup.py but this fix works better from a packager point of view. Moves the systemd unit files and daemon into /usr/lib and /usr/libexec dirs Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
index d79fc7d003..85575df7b5 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
@@ -23,6 +23,12 @@ inherit pypi features_check systemd setuptools3
REQUIRED_DISTRO_FEATURES = "systemd"
+do_install:append() {
+ mv ${D}${PYTHON_SITEPACKAGES_DIR}${exec_prefix}/* ${D}${exec_prefix}
+ mv ${D}${PYTHON_SITEPACKAGES_DIR}${sysconfdir} ${D}
+ mv ${D}${PYTHON_SITEPACKAGES_DIR}${base_libdir} ${D}
+}
+
RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
parted python3-pyparted multipath-tools \
lsof cryptsetup libblockdev \